App-V FAQ: What are the system requirements for App-V?


Operating system support for App-V is ultimately determined by the Microsoft Product Support Lifecycle. Note that the App-V 4.6 Client and Sequencer is required for 64-bit operating systems.

App-V Desktop Client

Full details for the client system requirements can be found on TechNet here:  Application Virtualization Client Hardware and Software Requirements. The App-V 4.5 and App-V 4.6 clients can be installed to the following operating systems 1:

  • Windows XP Professional Service Pack 2 and Service Pack 3
  • Windows Vista RTM/SP1/SP2 Business, Enterprise and Ultimate
  • Windows 7 Home Premium, Professional, Enterprise and Ultimate

Note, these are the operating system versions that Microsoft currently support, if you install the App-V client on other operating systems, Microsoft will not support the client on that OS.

App-V Remote Desktop Services Client

Full details for the client system requirements (including RDS) can be found on TechNet here:  Application Virtualization Client Hardware and Software Requirements. The App-V 4.5 and App-V 4.6 clients can be installed to the following operating systems 1:

  • Windows Server 2003 (Standard, Enterprise, Datacenter; SP1, SP2, R2, SP2+R2)
  • Windows Server 2008 (Standard, Enterprise, Datacenter; SP1, SP2)
  • Windows Server 2008 R2 (Standard, Enterprise, Datacenter)

App-V Management Server and Streaming  Server

The App-V Management Server and Streaming Server are 32-bit only but will install on 64-bit Windows. Full details for the server system requirements can be found on TechNet here: Application Virtualization System Requirements. The App-V 4.5 SP1 and SP2 server components can be installed on the following operating systems 1:

  • Windows Server 2003 (Standard, Enterprise, Datacenter; SP1, SP2, R2, SP2+R2)
  • Windows Server 2008 (Standard, Enterprise, Datacenter; SP1, SP2)
  • Windows Server 2008 R2 (Standard, Enterprise, Datacenter)

The App-V Management Console can be installed on all supported operating systems (included desktop OS’s).

SQL Server

The App-V Management Server relies on SQL Server to host the data store. The following versions of SQL Server are supported 1:

  • SQL Server 2000 (SP3a, SP4)
  • SQL Server 2005 (SP1, SP2, SP3)
  • SQL Server 2005 Express (all versions – non production only)
  • SQL Server 2008 Express (all versions – non production only)
  • SQL Server 2008 (SP0, SP1)

The Management Server should work with SQL Server 2008 R2; however I’m unaware if this is official policy.

App-V Sequencer

The App-V 4.6 Sequencer comes as 32-bit and 64-bit versions (the 4.5 Sequencer supports 32-bit only). Full details for the App-V Sequencer system requirements can be found on TechNet here: Application Virtualization Sequencer Hardware and Software Requirements. The App-V Sequencer is supported on the following operating systems 2:

  • Windows XP Professional Service Pack 2 and Service Pack 3
  • Windows Vista RTM/SP1/SP2 Business, Enterprise and Ultimate
  • Windows 7 Home Premium, Professional, Enterprise and Ultimate
  • Windows Server 2003 (Standard, Enterprise, Datacenter; SP1, SP2, R2, SP2+R2)
  • Windows Server 2008 (Standard, Enterprise, Datacenter; SP1, SP2)
  • Windows Server 2008 R2 (Standard, Enterprise, Datacenter – 4.6 only)

Note that the Sequencer is single threaded only – a fast CPU will help, but multiple CPUs will not.

Virtualisation

If you are considering running any of the App-V components on virtualised hardware, system requirements will remain the same. You can find support Microsoft’s support policies on virtualisation here:

Print Friendly